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Welcome to Simple Backup. 

Simple Backup is a backup program that is intended to be
very simple and easy to use - just plug in your backup device
and start back ing up.

We hope you will find this document useful. 
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1 How to get Password Safe

Password Safe is free for commercial use. Password Safe can be downloaded for Software Verify's
website at https://www.softwareverify.com.

This help manual is available in Compiled HTML Help (Windows Help files), PDF, and online.

Windows Help https://www.softwareverify.com/documentation/chm/passwordSafe.chm
PDF https://www.softwareverify.com/documentation/pdfs/passwordSafe.pdf
Online https://www.softwareverify.com/documentation/html/passwordSafe/index.html

Whilst Password Safe is free for commercial use, Password Safe is copyrighted software and is not in
the public domain. You are free to use the software at your own risk. You are not allowed to distribute
the software in any form, or to sell the software, or to host the software on a website.

Contact Software Verify at:

Software Verify Limited
Suffolk Business Park
Eldo House
Kempson Way
Bury Saint Edmunds
IP32 7AR
United Kingdom

email sales@softwareverify.com
web https://www.softwareverify.com
blog https://www.softwareverify.com/blog
twitter http://twitter.com/softwareverify

Visit our blog to read our articles on debugging techniques and tools.
Follow us on twitter to keep track of the latest software tools and updates.
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2 What does Password Safe do?

Password Safe allows you to easily manage passwords for all your accounts.

Just start the software, create a strong master password then start adding your account details.

Who is this software for?

This software is intended to be so easy to use that you can use this software even if you think of yourself
as someone that doesn't know how to use computers very well. 

That said, if you're a power user there are options that provide you with more control if you want it,
allowing you to create and manage multiple password safes, each with their own master password.

Where is the password safe stored?

The default password safe is stored in <windows drive>\users\<user
name>\AppData\local\SoftwareVerify\PasswordSafe\default.pws

For example: c:\users\david\AppData\local\SoftwareVerify\PasswordSafe\default.pws

Can I create and use more than one password safe?

Yes.

You can create as many password safes as you want. 

Each password safe can be stored where you want to store it on disk, on a network share, a USB key,
an external hard drive. The choice is yours.

Each password safe has it's own master password.

How is the account and password information kept safe?

The data for each account is encrypted using Microsoft's Data Protection API using the master password
for additional entropy when encrypting the data.

A detailed description of this process is provided by Microsoft.

· It uses proven cryptographic routines, such as the strong Triple-DES algorithm in CBC mode, the
strong SHA-1 algorithm, and the PBKDF2 password-based key derivation routine. 

· It uses proven cryptographic constructs to protect data. All critical data is cryptographically integrity
protected, and secret data is wrapped by using standard methods.

· It uses large secret sizes to greatly reduce the possibility of brute-force attacks to compromise the
secrets.

· It uses PBKDF2 with 4000 iterations to increase the work factor of an adversary trying to compromise
the password.
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· It sanity checks MasterKey expiration dates.
· It protects all required network communication with Domain Controllers by using mutually

authenticated and privacy protected RPC channels.
· It minimizes the risk of exposing any secrets, by never writing them to disk and minimizing their

exposure in swappable RAM.
· It requires Administrator privileges to make any modifications to the DPAPI parameters in the registry.
· It uses Windows File Protection to help protect all critical DLLs from online changes even by

processes with Administrator privileges.
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3 The user interface

The Password Safe user interface very simple.

A menu is provided to allow you to edit the settings, view the help and to exit the program.

There is a large button which will start or stop the backing up process.

A settings dialog is provided to allow you to customize which files are backed up or ignored. 

Support for identifying external backup devices is provided so that we can warn you when a different
backup device is connected compared to the last time you made a backup.

3.1 Menu

The main menu contains three menus, File, Settings and Help.

3.1.1 File

The File menu 

File  Tools
Displays the Tools menu for advanced users.

File  Exit
Closes Password Safe.

Tools menu

The tools menu contains password safe management options that provide great power over the password
safe databases.

Because it's possible to damage password safes with these options we put them on a secondary Tools
menu so that they couldn't get triggered by accident.
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The options are in three groups: 

1. Opening and closing password safes.
2. Creating password safes and saving password safes in a location of your choice.
3. Rebuilding the default password safe.

File  Open Default Password Safe

Use this option to open the default password safe.

You'll need to use this after working with a custom password safe, or if you entered an incorrect
password while trying to access the default password safe.

File  Open Password Safe...

Use this option to open a password safe that you previously saved using Save Password Safe As....

File  Close

Close any password safe that you are working with.

File  Create a New Password Safe...

Create a password safe without overwriting the default password safe.

File  Save Password Safe As...

Use this option to save a password safe in a location of your choice.

File  Rebuild Default Password Safe...

Use this option if you need to set the default password safe to known state.

All data in the default password safe will be destroyed.

Before you can use this option you have to confirm that you want to do this action.
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3.1.2 Edit

The Edit menu allows you to manage all the passwords in the password safe.

Edit  View Password...

View the details for this account.
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Edit  Edit Password...

Edit the details for this account.

A dialog is displayed to allow you edit all the details for this account.
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Edit  Add Password...

Create a new account.

A dialog is displayed to allow you enter all the details for this account.



The user interface 13

Copyright © 2019-2024 Software Verify Limited

Edit  Delete

Delete the selected password.

The password is deleted without confirmation.

Edit  Delete All

Delete all passwords.

You will be asked to confirm that you want to delete all passwords.
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3.1.3 Settings

The Settings menu controls editing of the settings controlling Password Safe

Settings  Edit Settings...

Displays the settings dialog so that you can edit the current settings.

Settings  First-Run Wizard...

Displays the First-Run Wizard so that you can configure the settings as if you'd never run the software
before.

3.1.4 Software Updates

The Software Updates menu controls how often software updates are downloaded.

If you've been notified of a new software release to Password Safe or just want to see if there's a new
version, this feature makes it easy to update.

  Software Updates menu  Check for software updates   checks for updates and shows the
software update dialog if any exist 

An internet connection is needed to be able to make contact with our servers.

 Before updating the software, close the help manual, and end any active session by closing
target programs.

If no updates are available, you'll just see this message:
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Software Update dialog

If a software update is available for Password Safe you'll see the software update dialog.

· Download and install   downloads the update, showing progress 

Once the update has downloaded, Password Safe will close, run the installer, and restart.

You can stop the download at any time, if necessary.

· Don't download...  Doesn't download, but you'll be prompted for it again next time you start
Password Safe 

· Skip this version...  Doesn't download the update and doesn't bother you again until there's an
even newer update 

· Software update options...  edit the software update schedule 

Problems downloading or installing?

If for whatever reason, automatic download and installation fails to complete:
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· Download the latest installer manually from the software verify website.  

Make some checks for possible scenarios where files may be locked by Password Safe as follows:

· Ensure Password Safe and its help manual is also closed

· Ensure any error dialogs from the previous installation are closed

You should now be ready to run the new version.

Software update schedule

Password Safe can automatically check to see if a new version of Password Safe is available for
downloading.

  Software Updates menu  Configure software updates   shows the software update schedule
dialog

The update options are:

· never check for updates 
· check daily (the default)
· check weekly
· check monthly  

The most recent check for updates is shown at the bottom.

Software update directory

It’s important to be able to specify where software updates are downloaded to because of potential
security risks that may arise from allowing the TMP directory to be executable. For example, to
counteract security threats it's possible that account ownership permissions or antivirus software blocks
program execution directly from the TMP directory.
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The TMP directory is the default location but if for whatever reason you're not comfortable with that, you
can specify your preferred download directory. This allows you to set permissions for TMP to deny
execute privileges if you wish.

  Software Updates menu  Set software update directory  shows the Software update
download directory dialog

An invalid directory will show the path in red and will not be accepted until a valid folder is
entered.

Example reasons for invalid directories include:

· the directory doesn't exist 
· the directory doesn't have write privilege (update can't be downloaded)
· the directory doesn't have execute privilege (downloaded update can't be run)

 When modifying the download directory, you should ensure the directory will continue to be valid.
Updates may no longer occur if the download location is later invalidated.

· Reset   reverts the download location to the user's TMP directory 

The default location is c:\users\[username]\AppData\Local\Temp 

3.1.5 Help

The Help menu controls displaying this help document and displaying information about Password Safe.
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Help menu  About Password Safe...  displays information about Password Safe.

Help menu  Readme and Version History...  displays the readme and version history.

Help menu  Help Topics...  displays this help file.

Help menu  Help PDF...  displays this help file in PDF format.

Help menu  Help on softwareverify.com...  display the Software Verify documentation web page
where you can view online documentation or download compiled HTML Help and PDF help documents.

Help menu  Blog...  display the Software Verify blog.

Help menu  Contact customer support...  displays the options for contacting customer support.

Click a link to contact customer support.

3.2 Main User Interface

The Password Safe user interface very simple.

There is a large button which will start or stop the backing up process.

A settings dialog is provided to allow you to customize which files are backed up or ignored. 

Support for identifying external backup devices is provided so that we can warn you when a different
backup device is connected compared to the last time you made a backup.



The user interface 19

Copyright © 2019-2024 Software Verify Limited

· Start Backing up Files  starts the backup process. 

If you've never configured Password Safe you are prompted to do this first. 

· Stop Backup  stops the backup process.

A dialog is displayed that shows which files were backed up and which files couldn't be backed
up.

3.3 Create password safe

This dialog helps you to create a secure master password that will be used to protect all your data.

Type your password into the Master Password field.

As you type the password strength indicator will change from red to green indicating how strong the
password is.

When you've created a strong or very strong password click OK. 
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Don't forget this password - if you do you'll be locked out of all the password details stored in this
password safe.

View

If you need to remind yourself of what you've typed, click the View button.

3.4 Master password

The Master Password dialog informs you which password safe is being opened and asks you for the
master password to open that password safe.

Enter the master password and click OK.

Correct master password

If the master password is correct the password safe will be loaded.

Incorrect master password

If the master password is not correct an error message will be displayed.

You can attempt to load the default password safe from the File >Tools > Open Default Password
Safe.. menu.

You can attempt to load the any password safe from the File >Tools > Open Password Safe.. menu.

View

If you need to remind yourself of what you've typed, click the View button.
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4 Settings dialog

The settings dialog allows you to configure how Password Safe behaves.

4.1 Auto Load

The Auto Load settings allow you to configure which password safe is automatically loaded when
Password Safe starts.
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· Load passwords when...  a password safe will be loaded when Password Safe starts 

· Don't load passwords when...  a password safe will not be loaded when Password Safe starts 

· Password file location  specify the default password safe location. This is the password that will
be loaded when Password Safe starts.

Reset All

Resets the options on all pages of the settings dialog to the default.

Reset

Resets just the options on this page of the settings dialog to the default.
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